Identity Chooser 1.8.3

Contact the developer last night about the issue with Identity Chooser 1.8.2 not working with Thunderbird 20 Beta. Received an email earlier today with version 1.8.3 which works fine now with Thunderbird 20 Beta. Version 1.8.3 has already been released on AMO or you can update via your Thunderbird Add-ons Manager by right-clicking on the add-on and selecting Find Updates.

Leave a comment

Your email address will not be published.


*